贺州在线是贺州的地方门户网站,网站开设聚人在贺州、贺州指南、贺州民生、贺州新闻、贺州天气预报、贺州美食、贺州生活、贺州旅游等频道,更多精彩尽在贺州在线属于贺州的本土网站。
首页 > 家居 > 通达信MACD分时指标公式推荐

通达信MACD分时指标公式推荐

2018-01-09 09:36:33 来源:贺州在线 标签:1.01)AND(VAR3AA 顺势 而上

  DRAWGBK(C》0,RGB(50,60,250),RGB(17,21,89),0,‘11’,0);H1:=MAX(DYNAINFO(3),DYNAINFO(5));L1:=MIN(DYNAINFO(3),DYNAINFO(6));P1:=H1-L1;阻力:=L1 P1*7/8,COLORGREEN;支撑:=L1 P1*0.5/8,COLORRED;中线:=(支撑 阻力)/2,COLORWHITE,POINTDOT;V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);趋势线:EMA(V11,3),LINETHICK2,COLORLIMAGENTA;V12:=(趋势线-REF(趋势线,1))/REF(趋势线,1)*100;准备买入:STICKLINE(趋势线《11,趋势线,11,5,0),COLORYELLOW;AA:=(趋势线《11)ANDFILTER((趋势线《=11),15)ANDC《中线;BB0:=REF(趋势线,1)《11ANDCROSS(趋势线,11)ANDC《中线;BB1:=REF(趋势线,1)《11ANDREF(趋势线,1)》6ANDCROSS(趋势线,11);BB2:=REF(趋势线,1)《6ANDREF(趋势线,1)》3ANDCROSS(趋势线,6);BB3:=REF(趋势线,1)《3ANDREF(趋势线,1)》1ANDCROSS(趋势线,3);BB4:=REF(趋势线,1)《1ANDREF(趋势线,1)》0ANDCROSS(趋势线,1);BB5:=REF(趋势线,1)《0ANDCROSS(趋势线,0);BB:=BB1=1ORBB2=1ORBB3=1ORBB4=1ORBB5=1;下单买入:STICKLINE(BB=1ANDC《中线,11,50,5,0),COLORRED;DRAWICON(BB=1ANDC《中线,55,1);DRAWTEXT(BB0,60,‘★买’),COLORRED;DRAWTEXT(AA,16,‘准备买入’),COLORYELLOW;准备卖出:STICKLINE(趋势线》89,趋势线,89,5,0),COLORWHITE;CC:=(趋势线》89)ANDFILTER((趋势线》89),15)ANDC》中线;DD0:=REF(趋势线,1)》89ANDCROSS(89,趋势线)ANDC》中线;DD1:=REF(趋势线,1)》89ANDREF(趋势线,1)《94ANDCROSS(89,趋势线);DD2:=REF(趋势线,1)》94ANDREF(趋势线,1)《97ANDCROSS(94,趋势线);DD3:=REF(趋势线,1)》97ANDREF(趋势线,1)》99ANDCROSS(97,趋势线);DD4:=REF(趋势线,1)》99ANDREF(趋势线,1)《100ANDCROSS(99,趋势线);DD5:=REF(趋势线,1)》100ANDCROSS(100,趋势线);DD:=DD1=1ORDD2=1ORDD3=1ORDD4=1ORDD5=1;下单卖出:STICKLINE(DD=1ANDC》中线,89,50,5,0),COLORGREEN;DRAWICON(DD=1ANDC》中线,45,2);DRAWTEXT(DD0,40,‘★卖’),COLORGREEN;DRAWTEXT(CC,84,‘准备卖出’),COLORWHITE;顶:89,COLORGREEN;底:11,COLORRED;中:50,POINTDOT,COLORWHITE;DRAWTEXT(ISLASTBAR,顶,‘顶’),COLORGREEN;DRAWTEXT(ISLASTBAR,底,‘底’),COLORRED;DRAWTEXT(ISLASTBAR,中,‘中’),COLORWHITE;{上出下买 三背}A:=MA(CLOSE,17) ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1));B:=MA(CLOSE,17) MA(CLOSE,17)-REF(MA(CLOSE,17),1);分水岭:IF(MA(CLOSE,17)《B,B,MA(CLOSE,17)),COLORFF00FF;操作线:分水岭-(EMA(C,3)-分水岭),COLOR00FFFF;PM:MA(C,5),COLORWHITE;IF(PM》REF(PM,1),PM,DRAWNULL),COLORRED;IF(PM=REF(PM,1),PM,DRAWNULL),COLORRED;IF(PM《REF(PM,1),PM,DRAWNULL),COLORFF9900;S:=(PM》操作线);DD11:=分水岭《REF(分水岭,1);IF(DD11,分水岭,DRAWNULL),COLOR00FF00;IF(S,分水岭,DRAWNULL),COLOR00FF00;DRAWICON(CROSS(分水岭,操作线),分水岭-0.1,1);{买入红箭头}A1:=BARSLAST(REF(CROSS(“MACD.DIF”,“MACD.DEA”),1));B1:=REF(C,A1 1)》CANDREF(“MACD.DIF”,A1 1)《“MACD.DIF”ANDCROSS(“MACD.DIF”,“MACD.DEA”);DRAWTEXT(B1》0,L-0.02,‘MACD底背离’),COLOR00FFFF;{MACD底背离}A2:=BARSLAST(REF(CROSS(“KDJ.K”,“KDJ.D”),1));B2:=REF(C,A2 1)》CANDREF(“KDJ.K”,A2 1)《“KDJ.K”ANDCROSS(“KDJ.K”,“KDJ.D”);DRAWTEXT(B2,L-0.10,‘KDJ底背离’),COLORFF00FF;{KDJ底背离}A3:=BARSLAST(REF(CROSS(“RSI.RSI1”,“RSI.RSI2”),1));B3:=REF(C,A3 1)》CANDREF(“RSI.RSI1”,A3 1)《“RSI.RSI1”ANDCROSS(“RSI.RSI1”,“RSI.RSI2”);DRAWTEXT(B3》0,L-0.18,‘RSI底背离’),COLOR0000FF;{RSI底背离}C1:=BARSLAST(REF(CROSS(“MACD.DEA”,“MACD.DIF”),1));D1:=REF(C,C1 1)《CANDREF(“MACD.DIF”,C1 1)》“MACD.DIF”ANDCROSS(“MACD.DEA”,“MACD.DIF”);DRAWTEXT(D1》0,H 0.16,‘MACD顶背离’),COLOR00FF00;{MACD顶背离}C2:=BARSLAST(REF(CROSS(“KDJ.D”,“KDJ.K”),1));D2:=REF(C,C2 1)《CANDREF(“KDJ.K”,C2 1)》“KDJ.K”ANDCROSS(“KDJ.D”,“KDJ.K”);DRAWTEXT(D2》0,H 0.08,‘KDJ顶背离’),COLORFFFFCC;{KDJ顶背离}C3:=BARSLAST(REF(CROSS(“RSI.RSI2”,“RSI.RSI1”),1));D3:=REF(C,C3 1)《CANDREF(“RSI.RSI1”,C3 1)》“RSI.RSI1”ANDCROSS(“RSI.RSI2”,“RSI.RSI1”);DRAWTEXT(D3》0,H 0.04,‘RSI顶背离’),COLORFF9900;{RSI顶背离};